(1) 早期安裝它的原因是鑑於手邊學習資源較多。

(2) 後來 vc6.0 有幾個功能讓我實在沒辦法接受,如沒有 long long int (只能用 __int64),這就算了,cout 沒 overload __int64,更氣人的是,拿之後的版本(vc2002) 來編譯幾乎必錯 < 錯在哪?大多是陣列/指標嚴謹度、 header 問題、UNICODE 問題 >

(3) 後來發現 vc 2008 之後, MFC 多了很多 ATL / class 東西,這件事讓我更不想回去裝 6.0。

(4) 不得已原因之一:一份老案是用 6.0 寫的,要改較新的版本嗎?當然繼續用下去啊!

(5) 不得已原因之二:這理由我自己都覺得蠻蝦的。原因是又接了一份小案要求用 VBA 完成,我知道 6.0 裡面有 APILoad.exe,但 2008 / 2010 我就是找不到!更妙的是,網路上找了 APILoad.exe,需要 DBLIST32.OCX 才能用 ;千辛萬苦找到了 DBLIST32.OCX 後,又說要 ComDlg32.OCX,至此完全不想再搞下去...

有找到幾份 API_GEN.exe 類似的東西,不過大多是個人寫的,筆者常用到的 API 沒全放上去 ( 像 process、memory、window management 這些並不齊全),它主要是 for VB / VB.Net。

如果找到 VBA_API_LOAD.exe 的話,我願意給它一個讚 ( 雖然這個讚好像沒什麼就是了... )

這是我裝 6.0 最蝦的原因了..

edisonx 發表在 痞客邦 PIXNET 留言(0) 人氣()